Unable to upload photos
Incident Report for Canva
Resolved
We are sorry for the trouble but the issue with uploading photos is now resolved. Thank you for your patience while we are fixing this.
Posted 8 months ago. Jan 02, 2019 - 17:30 AEDT
Investigating
We are aware of an issue wherein users can't upload photos. Our team is now aware of this issue and working double time to fix this the soonest possible time. Please stay tuned for more updates.
Posted 8 months ago. Jan 02, 2019 - 17:10 AEDT
This incident affected: Web Application (Image Uploads).