Some users may encounter an error or slowness when uploading files to Canva

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Oct 07, 2025 - 21:20 AEDT

Investigating

We've noticed an increase in failed and slow uploads in some regions, and are investigating
Posted Oct 07, 2025 - 20:43 AEDT
This incident affected: Media uploads and Document import.