Issues saving designs
Incident Report for
Canva
Resolved
This incident has been resolved. We hope everything is back to normal for you.
Posted
Nov
04
,
2020
-
03:19
AEDT
Investigating
Some users are having trouble with saving changes to their designs.
Posted
Nov
04
,
2020
-
01:29
AEDT
This incident affected: Web Application (Edit Designs).
×
Subscribe to Incident
Subscribe to updates for
Issues saving designs
via . You'll receive .