Can't access Canva (Error 500)
Incident Report for Canva
Resolved
This incident has been resolved.
Posted May 21, 2021 - 16:58 AEST
Update
We are continuing to investigate this issue.
Posted May 21, 2021 - 16:58 AEST
Investigating
Hello there, Canva is now back up and running again. Please refresh your browsers to take effect. Thank you for your patience while we're working on resolving this.
Posted May 21, 2021 - 16:46 AEST
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).