Incident-134
Incident Report for Canva
Resolved
This incident is now resolved.
Posted Oct 27, 2020 - 22:56 AEDT
Update
We are continuing to investigate this issue.
Posted Oct 27, 2020 - 22:41 AEDT
Investigating
We have become aware of an issue where users are unable to download designs.

Our engineers are working to resolve the issue and will keep you updated.
Posted Oct 27, 2020 - 21:16 AEDT
This incident affected: Web Application (Design Downloads / Sharing).