Some users can't place print order if certain payment methods are offered
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Aug 19, 2021 - 20:19 AEST
Investigating
We are currently investing an issue where some users are unable to place print orders if these payment methods are offered:

- Sofort
- iDeal
- Adyen Grabpay

The following regions are identified to be affected:
- Spain
- Italy
- Poland
- Germany
- Netherlands

Our engineers are currently working on having this issue fixed. An update will be provided once this issue has been addressed.
Posted Aug 19, 2021 - 18:26 AEST