Opening a design results to "Error 500"
Incident Report for Canva
Resolved
Our downtime is over! Thank you for your patience. Canva is up once again, check it out! :)
Posted 11 months ago. Sep 26, 2018 - 11:31 AEST
Investigating
Our downtime is over! Thank you for your patience. Canva is up once again, check it out! :)
Posted 11 months ago. Sep 26, 2018 - 11:22 AEST
This incident affected: Web Application (Edit Designs).