Designs are not loading in the Editor
Incident Report for Canva
Resolved
The fix has been rolled out, and we have verified that the issue is resolved. Thanks for your patience.
Posted Jul 14, 2019 - 02:12 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2019 - 01:23 AEST
Investigating
We're aware of an uploading issue that's currently affecting some of our users and our engineers are already investigating the issue.

Apologies for the inconvenience and thanks again for your patience.
Posted Jul 13, 2019 - 23:29 AEST
This incident affected: Web Application (Image Uploads, View Designs).