Export Error
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 14:32 AEDT
Investigating
We are currently investigating the issue to make sure that this is resolved the soonest possible time.
Posted Nov 06, 2020 - 13:59 AEDT
This incident affected: Web Application (Design Downloads / Sharing).