Collection stores in US and CA are temporarily under maintenance and will be back soon
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 02:11 AEDT
Identified
The issue has been identified and we are working on a fix. We appreciate your patience and understanding regarding this matter.
Posted Feb 21, 2023 - 17:39 AEDT