Scheduled Maintenance
Incident Report for Canva
Resolved
We have successfully completed the Scheduled Maintenance.
Posted May 30, 2021 - 17:21 AEST
Monitoring
We will be performing a short scheduled maintenance this Sunday, May 30, 2021, starting at exactly 5:00 pm AEST up until 5:20 pm AEST.

Canva will still be operational during this time, however, some users might experience degraded performance resulting in errors while accessing the platform.

Our team will be closely monitoring and we’ll update this page once everything has been completed.

Thanks,
Canva Team
Posted May 30, 2021 - 16:00 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Design Downloads / Sharing, View Designs, Edit Designs).