Downloading design causes "Something went wrong" error
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 10:37 AEST
Investigating
We are currently investigating on this issue and are working hard to resolve it as soon as possible.
Posted Apr 21, 2020 - 10:01 AEST
This incident affected: Web Application (Design Downloads / Sharing).