Some users may experience irrelevant errors when downloading designs
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 22:16 AEDT
Update
We are continuing to investigate this issue.
Posted Mar 08, 2024 - 21:22 AEDT
Investigating
Our team is aware of the issue and we are currently investigating the root cause
Posted Mar 08, 2024 - 21:21 AEDT
This incident affected: Downloading designs.