Unable to load designs from the Canva Homepage and unable to download designs
Incident Report for Canva
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 29, 2019 - 17:49 AEST
Investigating
We are currently investigating the issue.
Posted about 2 months ago. Jun 29, 2019 - 17:01 AEST