Users may experience issues accessing Canva's marketplace pages.
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Jul 08, 2023 - 06:39 AEST
Monitoring
The issue has been identified/ Apologies for the inconvenience.
Posted Jul 08, 2023 - 06:29 AEST