Some users may encounter an error loading canva
Incident Report for Canva
Resolved
This incident has now been resolved.
Posted Aug 25, 2022 - 23:55 AEST
Investigating
We are currently investigating an issue regarding loading the website where users may fail to load pages. Our team is now working on a fix.
Thank you for your patience and understanding.
Posted Aug 25, 2022 - 22:26 AEST
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).