Issue with Subscription Activation After Payment

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Apr 30, 2025 - 10:55 AEST

Monitoring

This is now mitigated. If you were affected, we will automatically process a refund for your purchase.
New subscription attempts are working so we recommend to subscribe again.

Thank you for your patience and understanding!
Posted Apr 29, 2025 - 10:56 AEST

Identified

We are currently aware of an issue where some users may experience problems with their subscription activating after payment.

Our team is actively working to resolve this as quickly as possible.

If you were affected, we will automatically process a refund for your purchase.

We recommend attempting to subscribe again once the issue has been fully resolved.

We will provide an update as soon as the fix is in place. Thank you for your patience and understanding.
Posted Apr 29, 2025 - 02:22 AEST
This incident affected: Billing and subscriptions.