We are continuing to monitor for any further issues.
Posted Jul 09, 2025 - 10:47 AEST
Update
We've implemented a fix and monitoring results.
Posted Jul 08, 2025 - 18:19 AEST
Monitoring
We've implemented a fix and monitoring results.
Posted Jul 08, 2025 - 17:32 AEST
Update
We are currently working on a resolution
Posted Jul 08, 2025 - 14:56 AEST
Identified
Users may have issues with: - Users are unable to view or save changes to designs - Users of CanvaAI making general knowledge queries or how to use Canva features may see failure messages - Realtime comments may not be working, and will need to refresh the page to see new comments - Application Notification may not be working, and users will need to refresh page to see new notifications - Timer and follow user on designs may not be working
Posted Jul 08, 2025 - 14:10 AEST
Update
We are still investigating it.
Posted Jul 08, 2025 - 13:39 AEST
Update
We are still investigating the issue
Posted Jul 08, 2025 - 13:33 AEST
Investigating
We are currently still investigating this issue.
Posted Jul 08, 2025 - 12:13 AEST
This incident affected: Editing designs, Viewing designs, Saving designs, and Downloading designs.