Some users may have issues accessing designs on Canva

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 14:19 AEST

Identified

The issue has been identified and our engineers are working to implement a fix.
Posted Jun 09, 2026 - 13:45 AEST

Investigating

Some users may have issues accessing Canva. Our teams are urgently looking into this and we will provide an update soon.
Posted Jun 09, 2026 - 13:41 AEST
This incident affected: Editing designs and Viewing designs.