Can't access Canva <HTML view> upon logging in
Incident Report for Canva
Resolved
We are pleased to inform you that the issue has now been fixed. Thank you for your patience while we are in the process of resolving this.
Posted 8 months ago. Dec 18, 2018 - 16:53 AEDT
Investigating
We’re currently aware of an issue where users from India can't access canva.com. Our engineers are already investigating the issue and we'll send an update as soon as possible.
Posted 8 months ago. Dec 17, 2018 - 17:59 AEDT