Issue with folders in Canva
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Jul
01
,
2022
-
11:10
AEST
Identified
We have identified an issue with uploading items to folders within ‘your library’
Posted
Jul
01
,
2022
-
10:49
AEST
×
Subscribe to Incident
Subscribe to updates for
Issue with folders in Canva
via . You'll receive .