Some users may experience difficulties with purchasing a domain or bringing across their own domain to Canva.
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Nov 03, 2023 - 13:46 AEDT
Investigating
We are continuing to investigate this issue.
Posted Nov 03, 2023 - 09:59 AEDT