Users of Focus Broadband are currently unable to access Canva.
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 12:48 AEDT
Identified
We're aware of an issue that's preventing some users who use Focus Broadband as their internet service provider from accessing Canva.

We will keep you updated.
Posted Jan 18, 2024 - 13:23 AEDT