Saving paused error and greyed out Download button
Incident Report for Canva
Resolved
Hi there, sorry for the hiccups. Canva is now back up and running. Please open a new page then copy-paste your current design and save or download from there. We appreciate your patience and understanding regarding this matter.
Posted Apr 21, 2020 - 19:31 AEST
Investigating
We are currently investigating this issue and are working hard to resolve it as soon as possible.
Posted Apr 21, 2020 - 17:00 AEST
This incident affected: Web Application (Design Downloads / Sharing, Edit Designs).