Can’t find Canva app on Google Play Store
Incident Report for Canva
Resolved
We are now back up and running again. Thank you so much for your patience while we're working on this. Please feel free to let us know if you need anything else. Happy designing!
Posted Sep 29, 2020 - 07:30 AEST
Investigating
We’re receiving reports from users that they can’t find the Canva App in Google Playstore.
We’re currently investigating the issue and working hard to resolve it as soon as possible.
Posted Sep 29, 2020 - 06:23 AEST
This incident affected: Mobile Applications (Android app).