Some users may have issues accessing Canva

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 07:03 AEST

Identified

Users may experience intermittent issues downloading designs. Our team are urgently working on a fix.
Posted Jun 16, 2026 - 06:30 AEST

Investigating

Some users may have issues accessing Canva. Our teams are urgently looking into this and we will provide an update soon.
Posted Jun 16, 2026 - 06:20 AEST
This incident affected: Downloading designs.