Users are having issues accessing designs

Incident Report for Canva

Resolved

This incident is resolved. Thank you for patience and understanding.
Posted Apr 23, 2026 - 10:28 AEST

Monitoring

The incident is now mitigated. We will continue to monitor and resolve after confirming accessing designs are stable.
Posted Apr 23, 2026 - 09:59 AEST

Investigating

Users are having issues accessing designs. Our engineers are urgently investigating the issue.
Posted Apr 23, 2026 - 09:48 AEST
This incident affected: Viewing designs.