New activity from the May 2019 security incident
Incident Report for Canva
Resolved
This incident has been resolved. Rest assured that we are committed in continuously improving our users' account security measures in order to avoid this in the future.
Posted May 01, 2020 - 12:44 AEST
Monitoring
Our systems detected an unusual number of attempted logins for user accounts which we believe were related to our May 2019 security incident. We have responded by forcibly resetting vulnerable passwords for users that use the email option to sign into Canva. Visit our in-depth support page for more details.
Posted Jan 12, 2020 - 04:25 AEDT